using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^:]+:[^:]+:\s*([^:]+)";
string input = @"ABC_Store:Clothes:Shirt:Blue_ABC_XYZ
ABC_Store:Clothes: Pants: Red_ABC_XYZ ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}