package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^:]+:[^:]+:\s*([^:]+)`)
var str = `ABC_Store:Clothes:Shirt:Blue_ABC_XYZ
ABC_Store:Clothes: Pants: Red_ABC_XYZ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}