$re = '/^[^:]+:[^:]+:\s*([^:]+)/m';
$str = 'ABC_Store:Clothes:Shirt:Blue_ABC_XYZ
ABC_Store:Clothes: Pants: Red_ABC_XYZ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);