using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<w:proofErr.+(?:""\/>)";
string input = @"<w:pPr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main""><w:autoSpaceDE w:val=""0""/><w:autoSpaceDN w:val=""0""/><w:adjustRightInd w:val=""0""/><w:spacing w:after=""0"" w:line=""240"" w:lineRule=""auto""/><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr></w:pPr><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellStart""/><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""gramStart""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t>student</w:t></w:r><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellEnd""/><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""gramEnd""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t xml:space=""preserve""> </w:t></w:r><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellStart""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t>learning</w:t></w:r><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellEnd""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t xml:space=""preserve""> </w:t></w:r><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellStart""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t>outcomes</w:t></w:r><w:proofErr xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:type=""spellEnd""/><w:r xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:rsidRPr=""008D22B1""><w:rPr><w:rFonts w:cs=""SerifGothicStd-Bold""/><w:b/><w:bCs/><w:sz w:val=""24""/><w:szCs w:val=""24""/></w:rPr><w:t>*</w:t></w:r><w:autoSpaceDE xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:val=""0""/><w:autoSpaceDN xmlns:w=""http://schemas.openxmlformats.org/wordprocessingml/2006/main"" w:val=""0""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}