import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<w:proofErr.+(?:\"\\/>)";
final String string = "<w:pPr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\"><w:autoSpaceDE w:val=\"0\"/><w:autoSpaceDN w:val=\"0\"/><w:adjustRightInd w:val=\"0\"/><w:spacing w:after=\"0\" w:line=\"240\" w:lineRule=\"auto\"/><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr></w:pPr><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"gramStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>student</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"gramEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t xml:space=\"preserve\"> </w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>learning</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t xml:space=\"preserve\"> </w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>outcomes</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>*</w:t></w:r><w:autoSpaceDE xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:val=\"0\"/><w:autoSpaceDN xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:val=\"0\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}