import re
regex = re.compile(r"<w:proofErr.+(?:\"\/>)")
test_str = "<w:pPr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\"><w:autoSpaceDE w:val=\"0\"/><w:autoSpaceDN w:val=\"0\"/><w:adjustRightInd w:val=\"0\"/><w:spacing w:after=\"0\" w:line=\"240\" w:lineRule=\"auto\"/><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr></w:pPr><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"gramStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>student</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"gramEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t xml:space=\"preserve\"> </w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>learning</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t xml:space=\"preserve\"> </w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellStart\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>outcomes</w:t></w:r><w:proofErr xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:type=\"spellEnd\"/><w:r xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:rsidRPr=\"008D22B1\"><w:rPr><w:rFonts w:cs=\"SerifGothicStd-Bold\"/><w:b/><w:bCs/><w:sz w:val=\"24\"/><w:szCs w:val=\"24\"/></w:rPr><w:t>*</w:t></w:r><w:autoSpaceDE xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:val=\"0\"/><w:autoSpaceDN xmlns:w=\"http://schemas.openxmlformats.org/wordprocessingml/2006/main\" w:val=\"0\"/>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")