#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/(.*?)[^so]?so"
Local $sString = "]凕�����0w.:pR^C74`�/j��g�<�懕^[�^D]�ᇕ�^Ev�LJPb�^TΫ�^Yϫ>" & @CRLF & _
"$�U^ZL��L^X���^Ric��4�9Й^\R�GyA�F�^M.˨��Ψ9F'˨$K^C^D^T^@^HU@^H^@^}(G^@^@^@^@^@^@^@^@^@^@^@^@^[Z@^@^@assets/libstlport_shared.soĝ^K`WT՝\�^@lib/armeabi-v7a/libBreakpad.so��^" & @CRLF & _
"var test = "My cow always gives milk";using Firmglobal.Confirmit.UserManagement;using Firm/asda/asdglobal.Framework.Security.Permissions;" & @CRLF & _
"using Firmglobal.Framework.Security;asdsdasd/lib/armeabi-v7a/libBreakpad.soas /lib/armeabi-v7a/libLocalPreview.so @^}(G^@ /lib/armeabi-v7a/libphotoeffect.so 7a@^}(G^@ /assets/libstlport_shared.so -a" & @CRLF & _
"<3123>/lib/zxc1/lib1.so/lib/zxc2/lib2.so/lib/zxc3/lib3.sosfdsf/lib/asdas/.so<123123>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")