# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/(.*?)[^so]?so"
test_str = ("]凕�����0w.:pR^C74`�/j��g�<�懕^[�^D]�ᇕ�^Ev�LJPb�^TΫ�^Yϫ>\n"
"$�U^ZL��L^X���^Ric��4�9Й^\\R�GyA�F�^M.˨��Ψ9F'˨$K^C^D^T^@^HU@^H^@^}(G^@^@^@^@^@^@^@^@^@^@^@^@^[Z@^@^@assets/libstlport_shared.soĝ^K`WT՝\\�^@lib/armeabi-v7a/libBreakpad.so��^\n"
"var test = \"My cow always gives milk\";using Firmglobal.Confirmit.UserManagement;using Firm/asda/asdglobal.Framework.Security.Permissions;\n"
"using Firmglobal.Framework.Security;asdsdasd/lib/armeabi-v7a/libBreakpad.soas /lib/armeabi-v7a/libLocalPreview.so @^}(G^@ /lib/armeabi-v7a/libphotoeffect.so 7a@^}(G^@ /assets/libstlport_shared.so -a\n"
"<3123>/lib/zxc1/lib1.so/lib/zxc2/lib2.so/lib/zxc3/lib3.sosfdsf/lib/asdas/.so<123123>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.