// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/(.*?)[^so]?so").unwrap();
let string = "]凕�����0w.:pR^C74`�/j��g�<�懕^[�^D]�ᇕ�^Ev�LJPb�^TΫ�^Yϫ>
$�U^ZL��L^X���^Ric��4�9Й^\\R�GyA�F�^M.˨��Ψ9F'˨$K^C^D^T^@^HU@^H^@^}(G^@^@^@^@^@^@^@^@^@^@^@^@^[Z@^@^@assets/libstlport_shared.soĝ^K`WT՝\\�^@lib/armeabi-v7a/libBreakpad.so��^
var test = \"My cow always gives milk\";using Firmglobal.Confirmit.UserManagement;using Firm/asda/asdglobal.Framework.Security.Permissions;
using Firmglobal.Framework.Security;asdsdasd/lib/armeabi-v7a/libBreakpad.soas /lib/armeabi-v7a/libLocalPreview.so @^}(G^@ /lib/armeabi-v7a/libphotoeffect.so 7a@^}(G^@ /assets/libstlport_shared.so -a
<3123>/lib/zxc1/lib1.so/lib/zxc2/lib2.so/lib/zxc3/lib3.sosfdsf/lib/asdas/.so<123123>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}