#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*(.*)\R+Horario"
Local $sString = " Orden de Trabajo" & @CRLF & _
" N° 020008766353" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" LA SERENA" & @CRLF & _
"Horario Atención: LU a VI de 08:30 a 13:00 y 14:30 a 19:00" & @CRLF & _
"Datos de Recepción:" & @CRLF & _
"Asesor: LOPEZ JHON Cita Previa: No Fecha: 28.12.2015" & @CRLF & _
"Celular: +56961267725 Movilidad: No Fecha Esti mada Entrega:" & @CRLF & _
"Mail: JHON.LOPEZG@INDUMOTORA.CL Jefe Taller: ANGELO ANDRADE REYES 11.01.2016" & @CRLF & _
"Cliente: 9001540-0 - CAROLINA ELISA ALVAREZ DAMM Teléfono(s): 95194457 -" & @CRLF & _
"Dirección: AV. SANTA MARIA 6560 DPTO 106 - E-Mail: CALVAREZ@UC.CL" & @CRLF & _
"Cía.Seguro: -" & @CRLF & _
"Liquidador: -" & @CRLF & _
"N°Siniestro: N° y Tipo Poliza: -" & @CRLF & _
"" & @CRLF & _
"Marca: Subaru Modelo: ALL NEW OUTBACK 2.5I AWD VIN: JF1BR9L95CG101698" & @CRLF & _
"Patente: FSTL39 Color: PLATEADO HIELO CLARO Motor: E476539" & @CRLF & _
"Año: 2013 Kms: 0 KM Lote: 0000232412" & @CRLF & _
"Cono/Ubic: 55 Col.Co/Ub: AMARILLO" & @CRLF & _
"N°Llave: N°Locker:" & @CRLF & _
"" & @CRLF & _
"Requerimientos del Cliente:" & @CRLF & _
"DYP:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Observaciones Inspección:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Inventario Vehículo:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Niv.Combustible:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Firma Cliente" & @CRLF & _
"Estos Valores son referenciales y están sujeto a confirmación. Indumotora One S.A. no se hace responsable por pérdida o daños al vehículo o artículos" & @CRLF & _
"" & @CRLF & _
"dejados en su interior. El Cliente declara que en el interior del vehículo no ha dejado ningún objeto de valor. Por la presente autorizo las reparaciones" & @CRLF & _
"" & @CRLF & _
"aquí descritas, juntamente con el material que sea necesario usar en ellas, también autorizo a ustedes y a sus empleados para que operen por calles y" & @CRLF & _
"" & @CRLF & _
"carreteras u otros sitios, a fin de efectuar las pruebas e inspecciones pertinentes." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")