# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\h*(.*)\R+Horario"
test_str = (" Orden de Trabajo\n"
" N° 020008766353\n\n\n"
" LA SERENA\n"
"Horario Atención: LU a VI de 08:30 a 13:00 y 14:30 a 19:00\n"
"Datos de Recepción:\n"
"Asesor: LOPEZ JHON Cita Previa: No Fecha: 28.12.2015\n"
"Celular: +56961267725 Movilidad: No Fecha Esti mada Entrega:\n"
"Mail: JHON.LOPEZG@INDUMOTORA.CL Jefe Taller: ANGELO ANDRADE REYES 11.01.2016\n"
"Cliente: 9001540-0 - CAROLINA ELISA ALVAREZ DAMM Teléfono(s): 95194457 -\n"
"Dirección: AV. SANTA MARIA 6560 DPTO 106 - E-Mail: CALVAREZ@UC.CL\n"
"Cía.Seguro: -\n"
"Liquidador: -\n"
"N°Siniestro: N° y Tipo Poliza: -\n\n"
"Marca: Subaru Modelo: ALL NEW OUTBACK 2.5I AWD VIN: JF1BR9L95CG101698\n"
"Patente: FSTL39 Color: PLATEADO HIELO CLARO Motor: E476539\n"
"Año: 2013 Kms: 0 KM Lote: 0000232412\n"
"Cono/Ubic: 55 Col.Co/Ub: AMARILLO\n"
"N°Llave: N°Locker:\n\n"
"Requerimientos del Cliente:\n"
"DYP:\n\n\n\n\n"
"Observaciones Inspección:\n\n\n\n\n"
"Inventario Vehículo:\n\n\n\n\n"
" Niv.Combustible:\n\n\n\n\n"
" Firma Cliente\n"
"Estos Valores son referenciales y están sujeto a confirmación. Indumotora One S.A. no se hace responsable por pérdida o daños al vehículo o artículos\n\n"
"dejados en su interior. El Cliente declara que en el interior del vehículo no ha dejado ningún objeto de valor. Por la presente autorizo las reparaciones\n\n"
"aquí descritas, juntamente con el material que sea necesario usar en ellas, también autorizo a ustedes y a sus empleados para que operen por calles y\n\n"
"carreteras u otros sitios, a fin de efectuar las pruebas e inspecciones pertinentes.\n"
"")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.