#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a[^>]*?href=(["\'])?((?:.(?!\1|>))*.?)\1?"
Local $sString = "<li class="navItem "><a href="/services/" lang="de" hreflang="de">Services</a></li>" & @CRLF & _
"<a class="iMacLink" href="/portfolio/" ><div class="iMacOverlay"></div><div class="">Super</div></a></div>" & @CRLF & _
"<div class="addthis_toolbox addthis_default_style">" & @CRLF & _
"<a itemprop="url" target="_blank" href="https://www.facebook.com/any-profile" title="facebook" class="facebookSite"><span class="icon-facebook"></span></a>" & @CRLF & _
"<a itemprop="url" target="_blank" href="https://twitter.com/any-profile" title="twitter" class="twitterSite"><span class="icon-twitter"></span></a>" & @CRLF & _
"<a itemprop="url" target="_blank" href="https://pinterest.com/any-profile" title="pinterest" class="pinterestSite"><span class="icon-pinterest"></span></a>" & @CRLF & _
"<a itemprop="url" target="_blank" href="//feeds.feedburner.comany-profile?format=xml" title="rss" class="rss"><span class="icon-rss"></span></a>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a class="social facebookProfil" href="http://www.facebook.com/any-profile">Facebook</a>" & @CRLF & _
"<a class="social facebookProfil" href='https://www.facebook.com/single-quotes'>Facebook</a>" & @CRLF & _
"<a class="social facebookProfil" href=https://www.facebook.com/no-quotes>Facebook</a>" & @CRLF & _
"<a class="social youtubeProfil" href="http://www.youtube.com/user/any-profile">Youtube</a>" & @CRLF & _
"" & @CRLF & _
"<a class="social vimeoProfil" href="http://vimeo.com/any-profile">Vimeo</a>" & @CRLF & _
"<a class="social xingProfil" href="https://www.xing.com/companies/any-profile">XING</a>" & @CRLF & _
"<a class="social twitterProfil" href="https://twitter.com/any-profile">Folge bei Twitter</a>" & @CRLF & _
"" & @CRLF & _
"<a href="https://www.instagram.com/p/CN-Kx40nOW0/">Instagram Beitrag</a>" & @CRLF & _
"<a href="http://instagram.com/quellenhofaachen">Instagram Profil</a>" & @CRLF & _
"<a href="https://www.instagram.com/explore/tags/url">Instagram Tag-Url</a>" & @CRLF & _
"<A href="https://www.Instagram.com/uppercase-link">Upercase-link</A>" & @CRLF & _
"" & @CRLF & _
"<a href="http://instagram.com/unique">Unique-test http</a>" & @CRLF & _
"<a href="//instagram.com/unique">Unique-test protocol relative</a>" & @CRLF & _
"<a href="https://instagram.com/unique">Unique-test https</a>" & @CRLF & _
"<a href="http://www.instagram.com/unique">Unique-test www</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")