using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*?href=([""\'])?((?:.(?!\1|>))*.?)\1?";
string input = @"<li class=""navItem ""><a href=""/services/"" lang=""de"" hreflang=""de"">Services</a></li>
<a class=""iMacLink"" href=""/portfolio/"" ><div class=""iMacOverlay""></div><div class="">Super</div></a></div>
<div class=""addthis_toolbox addthis_default_style"">
<a itemprop=""url"" target=""_blank"" href=""https://www.facebook.com/any-profile"" title=""facebook"" class=""facebookSite""><span class=""icon-facebook""></span></a>
<a itemprop=""url"" target=""_blank"" href=""https://twitter.com/any-profile"" title=""twitter"" class=""twitterSite""><span class=""icon-twitter""></span></a>
<a itemprop=""url"" target=""_blank"" href=""https://pinterest.com/any-profile"" title=""pinterest"" class=""pinterestSite""><span class=""icon-pinterest""></span></a>
<a itemprop=""url"" target=""_blank"" href=""//feeds.feedburner.comany-profile?format=xml"" title=""rss"" class=""rss""><span class=""icon-rss""></span></a>
</div>
<a class=""social facebookProfil"" href=""http://www.facebook.com/any-profile"">Facebook</a>
<a class=""social facebookProfil"" href='https://www.facebook.com/single-quotes'>Facebook</a>
<a class=""social facebookProfil"" href=https://www.facebook.com/no-quotes>Facebook</a>
<a class=""social youtubeProfil"" href=""http://www.youtube.com/user/any-profile"">Youtube</a>
<a class=""social vimeoProfil"" href=""http://vimeo.com/any-profile"">Vimeo</a>
<a class=""social xingProfil"" href=""https://www.xing.com/companies/any-profile"">XING</a>
<a class=""social twitterProfil"" href=""https://twitter.com/any-profile"">Folge bei Twitter</a>
<a href=""https://www.instagram.com/p/CN-Kx40nOW0/"">Instagram Beitrag</a>
<a href=""http://instagram.com/quellenhofaachen"">Instagram Profil</a>
<a href=""https://www.instagram.com/explore/tags/url"">Instagram Tag-Url</a>
<A href=""https://www.Instagram.com/uppercase-link"">Upercase-link</A>
<a href=""http://instagram.com/unique"">Unique-test http</a>
<a href=""//instagram.com/unique"">Unique-test protocol relative</a>
<a href=""https://instagram.com/unique"">Unique-test https</a>
<a href=""http://www.instagram.com/unique"">Unique-test www</a>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}