import re
regex = re.compile(r"<a[^>]*?href=([\"\'])?((?:.(?!\1|>))*.?)\1?", flags=re.IGNORECASE)
test_str = ("<li class=\"navItem \"><a href=\"/services/\" lang=\"de\" hreflang=\"de\">Services</a></li>\n"
"<a class=\"iMacLink\" href=\"/portfolio/\" ><div class=\"iMacOverlay\"></div><div class=\"\">Super</div></a></div>\n"
"<div class=\"addthis_toolbox addthis_default_style\">\n"
"<a itemprop=\"url\" target=\"_blank\" href=\"https://www.facebook.com/any-profile\" title=\"facebook\" class=\"facebookSite\"><span class=\"icon-facebook\"></span></a>\n"
"<a itemprop=\"url\" target=\"_blank\" href=\"https://twitter.com/any-profile\" title=\"twitter\" class=\"twitterSite\"><span class=\"icon-twitter\"></span></a>\n"
"<a itemprop=\"url\" target=\"_blank\" href=\"https://pinterest.com/any-profile\" title=\"pinterest\" class=\"pinterestSite\"><span class=\"icon-pinterest\"></span></a>\n"
"<a itemprop=\"url\" target=\"_blank\" href=\"//feeds.feedburner.comany-profile?format=xml\" title=\"rss\" class=\"rss\"><span class=\"icon-rss\"></span></a>\n"
"</div>\n\n\n"
"<a class=\"social facebookProfil\" href=\"http://www.facebook.com/any-profile\">Facebook</a>\n"
"<a class=\"social facebookProfil\" href='https://www.facebook.com/single-quotes'>Facebook</a>\n"
"<a class=\"social facebookProfil\" href=https://www.facebook.com/no-quotes>Facebook</a>\n"
"<a class=\"social youtubeProfil\" href=\"http://www.youtube.com/user/any-profile\">Youtube</a>\n\n"
"<a class=\"social vimeoProfil\" href=\"http://vimeo.com/any-profile\">Vimeo</a>\n"
"<a class=\"social xingProfil\" href=\"https://www.xing.com/companies/any-profile\">XING</a>\n"
"<a class=\"social twitterProfil\" href=\"https://twitter.com/any-profile\">Folge bei Twitter</a>\n\n"
"<a href=\"https://www.instagram.com/p/CN-Kx40nOW0/\">Instagram Beitrag</a>\n"
"<a href=\"http://instagram.com/quellenhofaachen\">Instagram Profil</a>\n"
"<a href=\"https://www.instagram.com/explore/tags/url\">Instagram Tag-Url</a>\n"
"<A href=\"https://www.Instagram.com/uppercase-link\">Upercase-link</A>\n\n"
"<a href=\"http://instagram.com/unique\">Unique-test http</a>\n"
"<a href=\"//instagram.com/unique\">Unique-test protocol relative</a>\n"
"<a href=\"https://instagram.com/unique\">Unique-test https</a>\n"
"<a href=\"http://www.instagram.com/unique\">Unique-test www</a>\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")