$re = '/(?<!https?:\/\/\S*)\bbitcoin.*?[\\\\s.,?!]/mi';
$str = 'Bitcoin price is going nuts", it would find it, but it was also take the following url and match it. https://versionone.vc/the-solar-bitcoin-convergence, messing up the url.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);