re = /(?<!https?:\/\/\S*)\bbitcoin.*?[\\s.,?!]/mi
str = 'Bitcoin price is going nuts", it would find it, but it was also take the following url and match it. https://versionone.vc/the-solar-bitcoin-convergence, messing up the url.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end