re = /(?m)(?:([a-zA-Z])(?!\1)|^)(([a-zA-Z])\3)(?!\3)/
str = 'assfdbfool
laaate
deeeeell
tjjr
pp'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result