import Foundation
let pattern = #"(?m)(?:([a-zA-Z])(?!\1)|^)(([a-zA-Z])\3)(?!\3)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
assfdbfool
laaate
deeeeell
tjjr
pp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)