using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^[A-Z]+( [A-Z]+){0,}$";
string input = @"Karan S'jet
Karan S#jet
John Jacob Jingleheimer-Schmidt
John Jacob Jingleheimer Schmidt
Nine of 3
zam man
Mr. X
##### ///
.hack//GU
John Doofus Boogaloo Zam bo
John Doofus Boogaloo Zam bo
5woo
Zippity
$%3egb
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}