$re = '/(?i)^[A-Z]+( [A-Z]+){0,}$/m';
$str = 'Karan S\'jet
Karan S#jet
John Jacob Jingleheimer-Schmidt
John Jacob Jingleheimer Schmidt
Nine of 3
zam man
Mr. X
##### ///
.hack//GU
John Doofus Boogaloo Zam bo
John Doofus Boogaloo Zam bo
5woo
Zippity
$%3egb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);