// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^[A-Z]+( [A-Z]+){0,}$").unwrap();
let string = "Karan S'jet
Karan S#jet
John Jacob Jingleheimer-Schmidt
John Jacob Jingleheimer Schmidt
Nine of 3
zam man
Mr. X
##### ///
.hack//GU
John Doofus Boogaloo Zam bo
John Doofus Boogaloo Zam bo
5woo
Zippity
$%3egb
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}