package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)href="(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)"|\[url\](mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\[\/url\]|\[url=(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\].*\[\/url\]`)
var str = `sdf<a href="mydomain1.com/asdfa">asfd</a> asdasfd
asf<a href="site.ru/kdkdk">asdfds</a> asdfasdfadsf
asfdasf
[url]superdomen.org.ru/dlsdl[/url] asdfasfd
asfasfdasfd
[url=superdomen.org.ru/d]...[/URL] asdfas
sdfsfda`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}