import re
regex = re.compile(r"href=\"(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\"|\[url\](mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\[\/url\]|\[url=(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\].*\[\/url\]", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("sdf<a href=\"mydomain1.com/asdfa\">asfd</a> asdasfd\n"
"asf<a href=\"site.ru/kdkdk\">asdfds</a> asdfasdfadsf\n"
"asfdasf\n"
"[url]superdomen.org.ru/dlsdl[/url] asdfasfd\n"
"asfasfdasfd\n"
"[url=superdomen.org.ru/d]...[/URL] asdfas\n"
"sdfsfda")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")