const regex = /href="(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)"|\[url\](mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\[\/url\]|\[url=(mydomain1\.com.*|site.ru.*|superdomen\.org\.ru.*)\].*\[\/url\]/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(mydomain1\\.com.*|site.ru.*|superdomen\\.org\\.ru.*)"|\\[url\\](mydomain1\\.com.*|site.ru.*|superdomen\\.org\\.ru.*)\\[\\\/url\\]|\\[url=(mydomain1\\.com.*|site.ru.*|superdomen\\.org\\.ru.*)\\].*\\[\\\/url\\]', 'gim')
const str = `sdf<a href="mydomain1.com/asdfa">asfd</a> asdasfd
asf<a href="site.ru/kdkdk">asdfds</a> asdfasdfadsf
asfdasf
[url]superdomen.org.ru/dlsdl[/url] asdfasfd
asfasfdasfd
[url=superdomen.org.ru/d]...[/URL] asdfas
sdfsfda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}