package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s]([\w]+)[\s]--[\s]\'([^\']+)`)
var str = `Contact=" (Contact){ Id -- '123' Email -- 'johnny@gmail.com' Name -- 'Johnny blah' Phone -- '3333337856' }â€`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}