$re = '/[\s]([\w]+)[\s]--[\s]\'([^\']+)/';
$str = 'Contact=" (Contact){ Id -- \'123\' Email -- \'johnny@gmail.com\' Name -- \'Johnny blah\' Phone -- \'3333337856\' }â€';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);