use strict;
my $str = 'Contact=" (Contact){ Id -- \'123\' Email -- \'johnny@gmail.com\' Name -- \'Johnny blah\' Phone -- \'3333337856\' }â€';
my $regex = qr/[\s]([\w]+)[\s]--[\s]\'([^\']+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}