package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]+$`)
var str = `34fq qsdfaafd
afasdf asgserg
4334a asdf a.asdf.
asdf asdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}