re = /[a-z]+$/m
str = '34fq qsdfaafd
afasdf asgserg
4334a asdf a.asdf.
asdf asdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end