$re = '/[a-z]+$/m';
$str = '34fq qsdfaafd
afasdf asgserg
4334a asdf a.asdf.
asdf asdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);