using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^( *)(?!# +console)(console\.log .*)$";
string input = @"# console.log 'saving input'
# console.log 'saving input'
console.log 'saving input'
# console.log 'saving input'
# console.log('saving input')
console.log('saving input', waf)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}