$re = '/^( *)(?!# +console)(console\.log .*)$/mi';
$str = '# console.log \'saving input\'
# console.log \'saving input\'
console.log \'saving input\'
# console.log \'saving input\'
# console.log(\'saving input\')
console.log(\'saving input\', waf)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);