re = /^( *)(?!# +console)(console\.log .*)$/mi
str = '# console.log \'saving input\'
# console.log \'saving input\'
console.log \'saving input\'
# console.log \'saving input\'
# console.log(\'saving input\')
console.log(\'saving input\', waf)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end