using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:^(?:(?:(?:(?:(?:0?[13578]|1[02])[- /.]31)|(?:(?:0?[13-9]|1[0-2])[- /.](?:29|30)))[- /.](?:1[6-9]|[2-9]\d)\d{2})|(?:0?2[- /.]29[- /.](?:(?:(?:1[6-9]|[2-9]\d)(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:(?:0?[1-9])|(?:1[0-2]))[- /.](?:0?[1-9]|1\d|2[0-8])[- /.](?:(?:1[6-9]|[2-9]\d)\d{2}))$)$";
string input = @"11-30-201";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}