import Foundation
let pattern = #"^(?:^(?:(?:(?:(?:(?:0?[13578]|1[02])[- /.]31)|(?:(?:0?[13-9]|1[0-2])[- /.](?:29|30)))[- /.](?:1[6-9]|[2-9]\d)\d{2})|(?:0?2[- /.]29[- /.](?:(?:(?:1[6-9]|[2-9]\d)(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:(?:0?[1-9])|(?:1[0-2]))[- /.](?:0?[1-9]|1\d|2[0-8])[- /.](?:(?:1[6-9]|[2-9]\d)\d{2}))$)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"11-30-201"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}