using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^""\n]*?""[^""\n]*?"")*[^""\n]*?)""[^""\n]*?\n[^""\n]*?""";
string substitution = @"$1\n";
string input = @"""This is a quote""
This is an end ""partial-
quote"" Here is more text.
This is an end ""partial-
quote w/o more text
This is an ""embedded"" quote
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}