// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^((?:[^"\n]*?"[^"\n]*?")*[^"\n]*?)"[^"\n]*?\n[^"\n]*?""#).unwrap();
let string = "\"This is a quote\"
This is an end \"partial-
quote\" Here is more text.
This is an end \"partial-
quote w/o more text
This is an \"embedded\" quote
";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}