re = /^((?:[^"\n]*?"[^"\n]*?")*[^"\n]*?)"[^"\n]*?\n[^"\n]*?"/m
str = '"This is a quote"
This is an end "partial-
quote" Here is more text.
This is an end "partial-
quote w/o more text
This is an "embedded" quote
'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result