package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\s(.)\d-]{6,}\d\b`)
var str = `hola me llamo juana mi número es el 692147849 tengo otro número 692 14 15 16 y tengo otro más el 692.123.123
y el otro número es el 968 23 43 45 fasdf y el núḿero 968 123 123 y si ahora pongo http://www.laweb.es/12/24/323/323/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}