using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[POE])[POE]*[A-DF-NQ-Z]?[POE]*$";
string input = @"PPEEOX
PO
POX
EEP
PPPXY
XYP
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}