$re = '/^(?=.*[POE])[POE]*[A-DF-NQ-Z]?[POE]*$/m';
$str = 'PPEEOX
PO
POX
EEP
PPPXY
XYP
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);