re = /^(?=.*[POE])[POE]*[A-DF-NQ-Z]?[POE]*$/m
str = 'PPEEOX
PO
POX
EEP
PPPXY
XYP
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end