import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.+href=[\"'](.*)[\"'].*>(.*(?:test|aa).*)<\\/a>";
final String string = "<A href=\"rwrwerwe\">rwewrtestewe</a> <a href='rwrwewre'>wrewreaa2rwe</a> <a href=\"rwrwewre\">notvalid</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}