using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\\/]|^)SV-14-[^_]*_S[12]([\\/]|$)";
string input = @"Text/SV-14-001_S1/
Text/SV-14-001_S2/
Text/SV-14-002_S1
SV-14-001_S2/
Text/SV-14-003_S1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}