import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\\\/]|^)SV-14-[^_]*_S[12]([\\\\/]|$)";
final String string = "Text/SV-14-001_S1/\n"
+ "Text/SV-14-001_S2/\n"
+ "Text/SV-14-002_S1\n"
+ "SV-14-001_S2/\n"
+ "Text/SV-14-003_S1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}