package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\\/]|^)SV-14-[^_]*_S[12]([\\/]|$)`)
var str = `Text/SV-14-001_S1/
Text/SV-14-001_S2/
Text/SV-14-002_S1
SV-14-001_S2/
Text/SV-14-003_S1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}