import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<cusip>(\\d{3}[a-zA-Z0-9]{6}|\\d{3}[a-zA-Z0-9]{5}))(\\s*([:-]?\\s*))(?P<price>((\\$)?\\s{0,2}\\d{2,3})((?=\\s)|(\\.\\d+)|(\\-(([0-2]\\d)|(3[0-2])))))";
final String string = "3138EAD9 100-32 3138EADB 3138EADB 1\n"
+ "$100\n"
+ "99-30\n"
+ "$98\n"
+ "100.00\n"
+ "$100.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}