const regex = /(?P<cusip>(\d{3}[a-zA-Z0-9]{6}|\d{3}[a-zA-Z0-9]{5}))(\s*([:-]?\s*))(?P<price>((\$)?\s{0,2}\d{2,3})((?=\s)|(\.\d+)|(\-(([0-2]\d)|(3[0-2])))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<cusip>(\\d{3}[a-zA-Z0-9]{6}|\\d{3}[a-zA-Z0-9]{5}))(\\s*([:-]?\\s*))(?P<price>((\\$)?\\s{0,2}\\d{2,3})((?=\\s)|(\\.\\d+)|(\\-(([0-2]\\d)|(3[0-2])))))', 'g')
const str = `3138EAD9 100-32 3138EADB 3138EADB 1
\$100
99-30
\$98
100.00
\$100.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}