re = /(?P<cusip>(\d{3}[a-zA-Z0-9]{6}|\d{3}[a-zA-Z0-9]{5}))(\s*([:-]?\s*))(?P<price>((\$)?\s{0,2}\d{2,3})((?=\s)|(\.\d+)|(\-(([0-2]\d)|(3[0-2])))))/
str = '3138EAD9 100-32 3138EADB 3138EADB 1
$100
99-30
$98
100.00
$100.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end