#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])"
Local $sString = "2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101" & @CRLF & _
"0.001,-0.03" & @CRLF & _
"2,3,-4,0,0,.03,2.01,.001,-.03,101" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)